Degraded API performance

Resolved
Degraded performance
Started about 1 year ago Lasted about 12 hours

Affected

API
Updates
  • Resolved
    Resolved

    This issue has been resolved and API response times are fully back to expected levels. We apologize for any inconvenience this incident may have caused

    The high latency was caused a combination of networking issues on our hosting infrastructure and a unusual high number of complex queries being executed in our database. We have provisioned more computing capacity for our database and further improved our auto-scaling capabilities to avoid this issue in the future.

  • Monitoring
    Monitoring

    We are seeing API response times further improving and you should see normal performance on all API endpoints.

    We continue to monitor our systems for any latency spikes.

    If you are still seeing slow response times, please contact technical support at support@focsec.com

  • Identified
    Identified

    This issue has been identified and we are working on a solution. Most API response times are back to normal, but we are still seeing some high latency spikes. Our team is working on additional fixed to fully restore performance.

    We are also seeing a small number of API errors (502) related to this issue.

  • Investigating
    Investigating

    We are seeing high latency response times on the API. We are actively investigating this issue.